Follow

So, because FreeBSD made kernel ABI changes between 12.1 and 12.2, my fileserver gets to sit on 12.1 until after its EOL to ensure that packages get rebuilt properly.

Why? openzfs-kmod is broken on 12.2 because of the ABI changes and I can't be bothered to rebuild the kernel and the kmod to get it working.

FreeBSD did this to me in the 11 series too. I wish they'd stop making non-emergency ABI changes inside major versions.

Sign in to participate in the conversation
nymwars

This is a single-user instance, namely for @sungo